Paper key?

Can any of you guys shed any light on what this is about? I have searched the preferences page but I cannot find ‘generate paper key’ anywhere. Screenshot_20210907-113416

Sorry @Kub933. Now came out of the closet: Discourse Encrypt plugin

Thanks @Miguel that worked :+1:

1 Like

@Miguel when I try to open a direct message (secret message) I get this: ‘You have enabled encryption, but did not activate it on this device.’

It’s weird because I have previously read and responded to direct messages on my laptop. When I try to enter the paper key that I have on record it says ‘incorrect paper key’

Is there a way to reset the paper key? How do I get around this?

Yes, but I was wating for your report (and @emp’s) on this here: Discourse Encrypt plugin - #5 by Miguel, from the same problem experienced by @geoffrey who managed to solve it.

There could be a problem with the plugin, but it would be good to know if you indeed now tried to log in with other device than your notebook.

Please read that post first and let me know how the issue turns out.

@Miguel yes, tried it on my phone as well with the same problem. I entered the paper key that I thought was generated initially, but I’m wondering if I maybe pressed the paper key option more than once and recorded the wrong string of words. So maybe its the wrong key.

Also there might be one more device that I first activated it on and maybe I mistakenly think its the laptop - will check that device and then get back to you. Otherwise I might have to just de-encrypt, lose the messages and start from scratch.

Interestingly I am able to read some messages. Is that because those users opted not to encrypt?

Yes, that can be a case

Probably, if none of the solutions I proposed there work for you.

If they show the padlock open, yes

Screenshot_20211114-202250_Samsung Internet

Hi Miguel, thanks for your help. Here is the screenshot.


The plugin is indicating that you have created the paper key but from another device. So it does not find it in this one.

Unfortunately, this can paint a real scenario or (apparently, from what others have experienced) a bug in the plugin.

Although the plugin it is asking you to enter that paper key on this device, the best thing to do is not that, but to try to open Alan’s messages first using any other devices you have ever used to enter to the forum (home PC, work PC, notebook, tablet, other cell phone).

Even if you have to wait to go to work to try, it’s the best bet